单臂路由
路由器配置:
1设置F0/0接口无IP,开启接口。
interface FastEthernet0/0。
no ip address
2在FA0/0接口上设置两个子接口,分别更改封装为DOT1Q,并设置各自的IP地址。
interface FastEthernet0/0.1。
encapsulation dot1Q 2。
ip address 1.1.1.1 255.255.255.0。
interface FastEthernet0/0.2。
encapsulation dot1Q 3。
ip address 2.2.2.1 255.255.255.0。
要注意的是这里的VLAN号码要和交换机中的VLAN号对应起来。
交换机配置:
首先在交换机上划分两个VLAN。
Vlan 2 name pc1。
Vlan 3 name pc2。
1 将交换机连接路由器的接口设置为TRUNK。
interface FastEthernet1/5。
switchport mode trunk。
2 将交换机连接两台PC的接口绑定到不同的VLAN中去。
interface FastEthernet1/11。
switchport access vlan 2。
interface FastEthernet1/12。
switchport access vlan 3。
PC配置:
给PC的F0/0接口设置与路由器对应子接口同一网段的IP地址。
PC1
interface FastEthernet0/0。
ip address 1.1.1.2 255.255.255.0。
PC2
interface FastEthernet0/0。
ip address 2.2.2.2 255.255.255.0。
给两个PC分别设置一条缺省路由,将出口指向F0/0,即划分入VLAN的接口。
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0。
至此,单臂路由的实验配置完成。测试的时候在PC1上PING一下PC2,应该可以看到结果。
要点:1,注意子接口的IP要和PC的IP在同一网段。2,要确保所有接口的配置正确,并都打开了接口。3,作为PC使用的路由器上必须配置有正确的路由条目。
例子:
s2960一台,r2811一台,PC2台。
SW#vlan database。
SW(vlan)#vlan 2。
VLAN 2 added:
Name: VLAN0002。
SW(vlan)#vlan 3。
VLAN 3 added:
Name: VLAN0003。
SW(vlan)#exit
SW(config)#int f0/2。
SW(config-if)#switchport mode access。
SW(config-if)#switchport access vlan 2。
SW(config-if)#no shutdown。
SW(config-if)#int f0/3。
SW(config-if)#switchport mode access。
SW(config-if)#switchport access vlan 3。
SW(config-if)#no shutdown。
SW(config-if)#int f0/1。
SW(config-if)#switchport mode trunk。
SW(config-if)#no shutdown。
路由器配置如下:
R(config)#int f0/0。
R(config-if)#no shutdown。
R(config-if)#int f0/0.2。
R(config-subif)#encapsulation dot1q 2。
R(config-subif)#ip address 192.168.2.254 255.255.255.0。
R(config-subif)#no shutdown。
R(config-subif)#int f0/0.3。
R(config-subif)#encapsulation dot1q 3。
R(config-subif)#ip address 192.168.3.254 255.255.255.0。
R(config-subif)#no shutdown。
R(config-subif)#end。
客户机配置如下:
HostA:
ip:192.168.2.1/24。
ip default-gateway:192.168.2.254。
HostB:
ip:192.168.3.1/24。
ip default-gateway:192.168.3.254。
n1好。
N1适合做旁路由(网关服务器),K2p拨号DHCP无线,其它全部交给N1,用过单臂路由也用过旁路由,单臂路由会偶尔断网,还是旁路由稳定点,不影响其它设备网络,N1处理AES比7621快很多,建议用N1作为跨栏运动之用。
1.单臂路由(图)
环境:一台路由器,一台二层交换机,两台pc机。
二层交换机的配置
一般模式:
Switch>
输入enable进入特权模式:
Switch>enable。
输入configure terminal进入全局配置模式:
Switch#configure terminal 。
Enter configuration commands, one per line. End with CNTL/Z.。
创建vlan 10 和 vlan 20:
Switch(config)#vlan 10。
Switch(config-vlan)#vlan 20。
Switch(config-vlan)# exit。
进入接口配置模式:
Switch(config)#interface fastEthernet 0/1。
把0/1变成trunk口(默认是access口)
Switch(config-if)#switchport mode trunk。
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down。
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up。
Switch(config-if)#exit。
进入接口配置模式分别把对应的接口,加入对应的vlan:
Switch(config)#interface fastEthernet 1/1。
Switch(config-if)#switchport mode access 。
Switch(config-if)#switchport access vlan 10。
Switch(config-if)#interface fastEthernet 2/1。
Switch(config-if)#switchport mode access 。
Switch(config-if)#switchport access vlan 20。
到此而层交换机配置完毕!
路由器的配置:
Router>
Router>enable。
Router#configure terminal 。
Enter configuration commands, one per line. End with CNTL/Z.。
Router(config)#inter fas 0/0。
Router(config-if)#no ip address 。
Router(config-if)#no shutdown。
注意:单臂路由的配置父接口一定要no shutdown。
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up。
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up。
Router(config-if)#exit。
Router(config)#int fas 0/0.10。
%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up。
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up。
Router(config-subif)#encapsulation dot1Q 10。
注意:在配置ip时一定要先封装802.1q协议。
Router(config-subif)#ip address 192.168.10.1 255.255.255.0。
Router(config-subif)#no shutdown 。
Router(config-subif)#int fas 0/0.20。
%LINK-5-CHANGED: Interface FastEthernet0/0.20, changed state to up。
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.20, changed state to up。
Router(config-subif)#ip address 192.168.20.1 255.255.255.0。
% Configuring IP routing on a LAN subinterface is only allowed if that。
subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,。
or ISL vLAN.
Router(config-subif)#encapsulation dot1Q 20。
Router(config-subif)#ip address 192.168.20.1 255.255.255.0。
Router(config-subif)#no shutdown 。
Router(config-subif)#。
查看路由表:
Router#show ip route 。
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP。
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area。
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2。
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP。
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area。
* - candidate default, U - per-user static route, o - ODR。
P - periodic downloaded static route。
Gateway of last resort is not set。
C 192.168.10.0/24 is directly connected, FastEthernet0/0.10。
C 192.168.20.0/24 is directly connected, FastEthernet0/0.20。
Router#
PC0的配置:
ip 192.168.10.10。
netmask 255.255.255.0。
gateway 192.168.10.1。
PC1的配置:
ip 192.168.20.20。
netmask 255.255.255.0。
gateway 192.168.20.1。
2.使用SVI实现VLAN间的通信(图)
环境:一台三层交换机,两台pc机。
三层交换机的配置:
Switch>enable 。
Switch#configure terminal 。
Enter configuration commands, one per line. End with CNTL/Z.。
创建vlan 10 20
Switch(config)#vlan 10。
Switch(config-vlan)#vlan 20。
Switch(config-vlan)#exit。
配置SVI接口ip
Switch(config)#interface vlan 10。
%LINK-5-CHANGED: Interface Vlan10, changed state to up。
Switch(config-if)#ip address 192.168.10.1 255.255.255.0。
Switch(config-if)#no shutdown 。
Switch(config-if)#interface vlan 20。
%LINK-5-CHANGED: Interface Vlan20, changed state to up。
Switch(config-if)#ip address 192.168.20.1 255.255.255.0。
Switch(config-if)#no shutdown 。
Switch(config-if)#exit。
改变接口模式并加入vlan
Switch(config)#interface fastEthernet 0/1。
Switch(config-if)#switchport mode access 。
Switch(config-if)#switchport access vlan 10。
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up。
Switch(config-if)#interface fastEthernet 0/2。
Switch(config-if)#switchport mode access 。
Switch(config-if)#switchport access vlan 20。
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up。
Switch(config-if)#。
看三层交换机的路由表:
Switch#show ip route 。
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP。
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area。
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2。
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP。
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area。
* - candidate default, U - per-user static route, o - ODR。
P - periodic downloaded static route。
Gateway of last resort is not set。
C 192.168.10.0/24 is directly connected, Vlan10。
C 192.168.20.0/24 is directly connected, Vlan20。
Switch#
两主机的配置与单臂路由中两主机的配置一样。
3.跨交换机实现VLAN间的通信(图)
环境:一台三层交换机,两台二层交换机,两台pc机。
三层交换机的配置(SW3)
Switch>enable。
Switch#configure terminal 。
Enter configuration commands, one per line. End with CNTL/Z.。
创建vlan 10 、 20 并设置ip。
Switch(config)#vlan 10。
Switch(config-vlan)#vlan 20。
Switch(config-vlan)#exit。
Switch(config)#interface vlan 10。
%LINK-5-CHANGED: Interface Vlan10, changed state to up。
Switch(config-if)#ip address 192.168.10.1 255.255.255.0。
Switch(config-if)#no shutdown 。
Switch(config-if)#interface vlan 20。
%LINK-5-CHANGED: Interface Vlan20, changed state to up。
Switch(config-if)#ip address 192.168.20.1 255.255.255.0。
Switch(config-if)#no shutdown 。
Switch(config-if)#exit。
设置接口模式并加入相应的vlan(注意trunk口的设置)
Switch(config)#interface fastEthernet 0/1。
Switch(config-if)#switchport mode trunk。
Switch(config-if)#interface fastEthernet 0/1。
Switch(config-if)#switchport access vlan 10。
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up。
Switch(config)#interface fastEthernet 0/2。
Switch(config-if)#switchport mode trunk 。
Switch(config-if)#interface fastEthernet 0/2。
Switch(config-if)#switchport access vlan 20。
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up。
Switch#
看路由表
Switch#show ip route 。
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP。
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area。
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2。
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP。
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area。
* - candidate default, U - per-user static route, o - ODR。
P - periodic downloaded static route。
Gateway of last resort is not set。
C 192.168.10.0/24 is directly connected, Vlan10。
C 192.168.20.0/24 is directly connected, Vlan20。
SW21的配置
Switch>enable。
Switch#configure terminal 。
Enter configuration commands, one per line. End with CNTL/Z.。
Switch(config)#vlan 10。
Switch(config-vlan)#exit。
Switch(config)#interface fastEthernet 0/1。
Switch(config-if)#switchport mode trunk。
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down。
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up。
Switch(config-if)#interface fastEthernet 1/1。
Switch(config-if)#switchport mode access 。
Switch(config-if)#switchport access vlan 10。
Switch(config-if)#exit。
Switch(config)#。
SW22的配置
Switch>
Switch>en
Switch#
Switch#configure ter。
Enter configuration commands, one per line. End with CNTL/Z.。
Switch(config)#inter fas 1/1。
Switch(config-if)#switchport mode trunk。
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/1, changed state to down。
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/1, changed state to up。
Switch(config-if)#switchport mode access 。
Switch(config-if)#inter fas 2/1。
Switch(config-if)#switchport mode trunk。
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2/1, changed state to down。
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2/1, changed state to up。
Switch(config-if)#exit。
Switch(config)#vlan 20。
Switch(config-vlan)#inter fas 1/1。
Switch(config-if)#switchport access vlan 20。
Switch(config-if)#。
注意:两交换机之间的链接是trunk链路。
4.以上配置在模拟器上都可实现。
在模拟器上配置其中pc图片
上述三种方式pc机的配置都一样。
1. 打开思科模拟器软件,找出一台2811类的路由器和两台2960类的交换机,4台PC电脑,并用正确的线缆将各个设备互相连接起来,如下图所示:
2.给所有设备都重新命名,路由器命名为r1,一交换机命名为sw1,另一交换机命名为sw2,如下图所示:
3. 先配置路由器r1先,配置命令为:
r1(config)#int f0/0。
r1(config-if)#no sh。
再配置路由器设备的远程登录和密码保护,配置命令为:
r1(config)#lin vty 0 4。
r1(config-line)#login local。
r1(config-line)#username admin password cisco。
r1(config-line)#exit。
r1(config)#enable secret cisco。
r1(config)#service password-encrption (此命令为加密所有口令)。
如下图所示:
4.配置交换机sw1,配置命令是:
sw1(config)#int vlan 1。
sw1(config-if)#ip add 192.168.1.2 255.255.255.0。
sw1(config-if)#no sh。
sw1(config-if)#ex。
sw1(config)#ip default-gateway 192.168.1.1。
再用相同方法配置sw2,如下图所示:
5. 配置vlan设定,在sw1上划分vlan 2,3,将相应端口加入其中,配置命令为:
sw1#conf t
Enter configuration commands, one per line. End with CNTL/Z.。
sw1(config)#vlan 2。
sw1(config-vlan)#ex。
sw1(config)#vlan 3。
sw1(config-vlan)#ex。
sw1(config)#int f0/4。
sw1(config-if)#switchport mode access。
sw1(config-if)#switchport access vlan 2。
sw1(config-if)#int f0/5。
sw1(config-if)#switchport mode access。
sw1(config-if)#switchport access vlan 3。
sw1(config-if)#ex。
用相同方法在sw3上面划分vlan,并将相应的端口加入其中,如下图所示:
6.配置单臂路由,实现valn1,2,3之间的互访,配置sw1接口f0/1为主干链路,配置命令是:
sw1(config)#int f0/1。
sw1(config-if)#switchport mode trunk。
sw1(config-if)#no sh。
如下图所示:
7.在路由器r1上进行封装,配置命令如下图所示:
r1#conf t
Enter configuration commands, one per line. End with CNTL/Z.。
r1(config)#int f0/0。
r1(config-if)#no shut。
r1(config)#int f0/0.1。
r1(config-subif)#encapsulation dot1Q 1。
r1(config-subif)#ip add 192.168.1.1 255.255.255.0。
r1(config-subif)#ex。
r1(config)#int f0/0.2。
r1(config-subif)#encapsulation dot1Q 2。
r1(config-subif)#ip add 192.168.2.1 255.255.255.0。
r1(config-subif)#ex。
r1(config)#int f0/0.3。
r1(config-subif)#encapsulation dot1Q 3。
r1(config-subif)#ip add 192.168.3.1 255.255.255.0。
r1(config-subif)#no sh。
r1(config-subif)#ex。
如下图所示:
8.配置DHCP服务器,即是配置路由器r1,配置命令是:
r1#enable
r1#conf t
r1(config)#ip dhcp excluded-address 192.168.2.1。
r1(config)#ip dhcp pool vlan2。
r1(dhcp-config)#net 192.168.2.0 255.255.255.0。
r1(dhcp-config)#default-router 192.168.2.1。
r1(dhcp-config)#dns-server 100.1.1.2。
r1(config)#ip dhcp excluded-address 192.168.3.1。
r1(config)#ip dhcp pool vlan3。
r1(dhcp-config)#net 192.168.3.0 255.255.255.0。
r1(dhcp-config)#dns-server 100.1.1.2。
r1(dhcp-config)#ex。
9. 现在PC之间可以自动获取IP地址和网关了,如下图所示:
vlan间路由的方法主要有三种。
1.通过路由器上多个接口实现
2.通过路由器上一个接口即单臂路由实现。
3.通过三层交换实现
下面将每一中实现方法配合实验说明。
第一:通过路由器上多个接口实现。
将交换机上用于和路由器互联的每个端口设为访问链接 ,然后分别用网线与路由器上的独立端口互联。如下图所示,交换机上有2个VLAN,那么就需要在交换机上预留2个端口用于与路由器互联;路由器上同样需要有2个端口;两者间用2条网线分别连接。
四个vlan
vlan11 网关10.0.11.1 主机10.0.11.2。
vlan21 网关10.0.21.1 主机10.0.21.2。
vlan31 网关10.0.31.1 主机10.0.31.2。
vlan41 网关10.0.41.1 主机10.0.41.2。
在交换机switch上做配置
vlan 11 创建vlan 11。
interface f0/0 vlan绑定到端口。
switchport mode access。
switchport access vlan 11。
下同,依次配置四个vlan……
将vlan11中的一个端口与路由器端口连接(路由器端口地址为vlan11 网关)
将vlan21中的一个端口与路由器端口连接 (路由器端口地址为vlan21 网关)
将vlan31中的一个端口与路由器端口连接 (路由器端口地址为vlan31 网关)
将vlan41中的一个端口与路由器端口连接 (路由器端口地址为vlan41 网关)
在router1上配置
vlan11的网关地址:
interface f0/0
ip address 10.0.11.1 255.255.255.0。
no shutdown
下同,依次配置四个接口ip……
如果采用这个办法,大家应该不难想象它的扩展性很成问题。每增加一个新的VLAN,都需要消耗路由器的端口和交换机上的访问链接,而且还需要重新布设一条网线。而路由器,通常不会带有太多LAN接口的。新建VLAN时,为了对应增加的VLAN所需的端口,就必须将路由器升级成带有多个LAN接口的高端产品,这部分成本、还有重新布线所带来的开销,都是的这种接线法成为一种不受欢迎的办法。
第二:通过路由器上一个接口即单臂路由实现。
第二种办法“不论VLAN数目多少,都只用一条网线连接路由器与交换机”呢?当使用一条网线连接路由器与交换机、进行VLAN间路由时,需要用到汇聚链接。
三个vlan
vlan11 网关192.168.1.1 主机192.168.1.2。
vlan21 网关192.168.2.1 主机192.168.2.2。
vlan31 网关192.168.3.1 主机192.168.3.2 192.168.3.3。
交换机 switch0 做做配置。
创建三个 vlan
vlan 11
vlan 21
vlan 31
端口绑定vlan
interface f0/0
switchport mode accedd。
switchport access vlan 11。
下同,依次在其余两个端口绑定vlan……
接着开通一个端口为 trunk 中继端口 (与switch1 中继链接)。
interface f0/24。
switchport mode trunk。
交换机 switch1 做配置。
创建 vlan
vlan 31
端口绑定vlan
interface f0/3
switchport mode access。
switchport access vlan 31。
开通一个端口为 trunk 中继端口(与switch0 中继链接)。
interface f0/24。
switchport mode trunk。
再开通一个端口为 trunk 中继汇聚链接端口(与路由器router0链接)
interface f0/24。
switchport mode trunk。
配置router0 路由器
创建三个子接口并配置(一定要注意封装)
interface f0/0.1。
encapsulation dot1q 11 //以802.1q协议封装, 11为vlan的id 格式 encapsulation [isl/dot1q] vlan。
ip address 192.168.1.1 255.255.255.0。
interface f0/0.2。
encapsulation dot1q 21 //以802.1q协议封装, 21为vlan的id 格式 encapsulation [isl/dot1q] vlan。
ip address 192.168.2.1 255.255.255.0。
interface f0/0.3。
encapsulation dot1q 31 //以802.1q协议封装, 31为vlan的id 格式 encapsulation [isl/dot1q] vlan。
ip address 192.168.3.1 255.255.255.0。
采用这种方法的话,即使之后在交换机上新建VLAN,仍只需要一条网线连接交换机和路由器。 用户只需要在路由器上新设一个对应新VLAN的子接口就可以了 。与前面的方法相比,扩展性要强得多,也不用担心需要升级LAN接口数目不足的路由器或是重新布线。
进行VLAN间通信时,即使通信双方都连接在同一台交换机上,也必须经过:
发送方——交换机——路由器——交换机——接收方 这样一个流程。
第三:通过三层交换机实现第三次交换。
用路由器进行VLAN间路由的话,随着VLAN之间流量的不断增加,很可能导致路由器称为整个网络的瓶颈。
交换机使用被称为ASIC(Application Specified Integrated Circuit)的专用硬件芯片处理数据帧的交换操作,在很多机型上都能实现以缆线速度(Wired Speed)交换。
而路由器,则基本上是基于软件处理的。即使以缆线速度接收到数据包,也无法在不限速的条件下转发出去,因此会成为速度瓶颈。就VLAN间路由而言,流量会集中到路由器和交换机互联的汇聚链路部分,这一部分尤其特别容易成为速度瓶颈。并且从硬件上看,由于需要分别设置路由器和交换机,在一些空间狭小的环境里可能连设置的场所都成问题。
为了解决上述问题。三层交换机应运而生。
三层交换机,本质上就是“带有路由功能的(二层)交换机”。路由属于OSI参照模型中第三层网络层的功能,因此带有第三层路由功能的交换机才被称为“三层交换机”。
其以vlan的虚端口为接口,vlan端口间的通信由交换机内部路由模块实现。
关于三层交换机的内部结构,可以参照下面的简图。
有如下图所示的4台计算机与三层交换机互联。当使用路由器连接时,一般需要在LAN接口上设置对应各VLAN的子接口;而三层交换机则是在内部生成“VLAN 接口(VLAN Interface)”。VLAN接口,是用于各VLAN收发数据的接口。(注:在Cisco的Catalyst 系列交换机上,VLAN Interface被称为 SVI -- Switch Virtual Interface)。
具体实验1:主机直接连接三层交换机。
在三层switch上创建两个vlan vlan11和vlan22。
Switch(config)#vlan 11。
Switch(config-vlan)#vlan 22。
Switch#show vlan brief //查看结果。
VLAN Name Status Ports。
---- -------------------------------- --------- -------------------------------。
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4。
Fa0/5, Fa0/6, Fa0/7, Fa0/8。
Fa0/9, Fa0/10, Fa0/11, Fa0/12。
Fa0/13, Fa0/14, Fa0/15, Fa0/16。
Fa0/17, Fa0/18, Fa0/19, Fa0/20。
Fa0/21, Fa0/22, Fa0/23, Fa0/24。
Gig1/1, Gig1/2。
11 VLAN0011 active 。
22 VLAN0022 active。
将交换机端口绑定到vlan
Switch(config)#interface f0/1。
Switch(config-if)#switchport access vlan 11。
Switch(config-if)#interface f0/2。
Switch(config-if)#switchport access vlan 11。
Switch(config)#interface f0/3。
Switch(config-if)#switchport access vlan 22。
Switch(config-if)#interface f0/4。
Switch(config-if)#switchport access vlan 22。
在三层交换机上配置vlan
Switch(config)#interface vlan 11。
Switch(config-if)#ip address 10.0.1.1 255.255.255.0。
Switch(config-if)#no shutdown。
Switch(config)#interface vlan 22。
Switch(config-if)#ip address 10.0.2.1 255.255.255.0。
Switch(config-if)#no shutdown。
具体实验2:二层交换机连接三层交换机。
配置各主机ip,配置二层交换机vlan并绑定到端口。
Switch(config)#vlan 11 //创建vlan 11。
Switch(config-vlan)#vlan 22 //创建vlan 22。
Switch(config-vlan)#end。
Switch#show vlan brief。
VLAN Name Status Ports。
---- -------------------------------- --------- -------------------------------。
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4。
Fa0/5, Fa0/6, Fa0/7, Fa0/8。
Fa0/9, Fa0/10, Fa0/11, Fa0/12。
Fa0/13, Fa0/14, Fa0/15, Fa0/16。
Fa0/17, Fa0/18, Fa0/19, Fa0/20。
Fa0/21, Fa0/22, Fa0/23, Fa0/24。
Gig1/1, Gig1/2。
11 VLAN0011 active 。
22 VLAN0022 active 。
1002 fddi-default active 。
1003 token-ring-default active 。
1004 fddinet-default active 。
1005 trnet-default active。
Switch(config)#interface range f0/1-2 //将接口 f0/1 f0/2 分配给 vlan11。
Switch(config-if-range)#switchport access vlan 11。
Switch(config)#interface range f0/3-4 //将接口 f0/3 f0/4 分配给 vlan22。
Switch(config-if-range)#switchport access vlan 22。
Switch(config)#interface f0/24 //将接口 f0/24 设置为与三层switch 连接的 turnk 线路。
Switch(config-if)#switchport mode trunk。
Switch(config-if)#switchport trunk allowed vlan all //允许所有vlan通过f0/24端口。
对三层交换机进行配置: 。
Switch(config)#vlan 11 //创建 vlan 11。
Switch(config-vlan)#vlan 22 //创建 vlan 22。
Switch(config)#int f0/24。
Switch(config-if)#switchport mode trunk //配置三层设备与二层设备连接的f0/1为trunk模式。
Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.。
Switch(config-if)#switchport trunk allowed vlan all //允许所有vlan通过f0/1端口。
Switch(config-if)#no shutdown //激活端口。
Switch(config-if)#exit。
Switch(config)#ip routing //使用三层设备的路由功能。
Switch(config)#int vlan 11 //进入vlan 11配置模式虚拟端口。
%LINK-5-CHANGED: Interface Vlan2, changed state to up Switch(config-if)#。
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2, changed state to up。
Switch(config-if)#ip address 10.0.1.1 255.255.255.0 / /配置vlan 11的ip地址。
Switch(config-if)#no shutdown //激活端口 Switch(config-if)#exit。
Switch(config)#int vlan 22 //进入vlan22 配置虚拟端口。
Switch(config-if)#ip address 10.0.2.1 255.255.255.0。
Switch(config-if)#no shutdown。
Switch(config-if)#exit。
Switch(config)#do show ip route // 查看配置结果。
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP。
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area。
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2。
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP。
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area。
* - candidate default, U - per-user static route, o - ODR。
P - periodic downloaded static route。
Gateway of last resort is not set。
10.0.0.0/24 is subnetted, 2 subnets。
C 10.0.1.0 is directly connected, Vlan11。
C 10.0.2.0 is directly connected, Vlan22。
Switch(config)#exit //退出保存。
Switch#
%SYS-5-CONFIG_I: Configured from console by console。
Switch#wr
Building configuration...。
原文地址:http://www.qianchusai.com/n1%E5%8D%95%E8%87%82%E8%B7%AF%E7%94%B1.html